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Chapter 1 - Introduction 

About Navicat BI Viewer 

Navicat BI Viewer is an easy-to-use tool for viewing BI workspace files. With its friendly Graphical User Interface (GUI), 

Navicat BI Viewer allows you to navigate workspaces designed by Navicat's BI feature or Navicat BI. You can access 

local workspace files, or workspace files stored in Navicat Cloud or Navicat On-Prem Server. 

Navicat BI Viewer allows you to share workspace files with someone who does not have Navicat and Navicat BI running 

on his computer but has Navicat BI Viewer installed. It highly increases the flexibility and convenience for viewing 

workspace files. It also gives you the ability to export charts and dashboards to PDF files and other image file formats. 

Navicat BI Viewer is available on three platforms - Microsoft Windows, macOS and Linux. 

For details, visit our website: https://www.navicat.com 

Requirements 

Supported Operating Systems 

Windows 

• Microsoft Windows 7, Windows 8, Windows 8.1, Windows 10, Windows 11, Server 2012, Server 2016, Server 

2019, Server 2022 

macOS 

• macOS 11 Big Sur, macOS 12 Monterey, macOS 13 Ventura, macOS 14 Sonoma, macOS 15 Sequoia 

Linux 

x86_64 

• Debian 10, Debian 11, Debian 12, Ubuntu 20.04, Ubuntu 22.04, Ubuntu 24.04, Fedora 38, Fedora 39, Fedora 

40, Linux Mint 20, Linux Mint 21, Deepin 20, KylinOS Desktop 10 

aarch64 

• Debian 11, Debian 12, Ubuntu 22.04, Ubuntu 24.04, Fedora 38, Fedora 39, Fedora 40, Linux Mint 20, Linux Mint 

21, KylinOS Desktop 10 

Installation 

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation. 

Installation for Download Version 

https://www.navicat.app/
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1. Download Navicat BI Viewer Windows version. 

2. Open the .exe file. 

3. Click Next at the Welcome Screen. 

4. Read the License Agreement. Accept it and click Next. 

5. Accept the location of the program icons by clicking Next. If you wish to change the destination of the folder, 

click Browse. 

6. Follow the remaining steps. 

Installation for CD Version 

1. Load the Navicat BI Viewer CD Installation disk into the CD-ROM drive. 

2. Open the .exe file. 

3. Click Next at the Welcome Screen. 

4. Read the License Agreement. Accept it and click Next. 

5. Accept the location of the program icons by clicking Next. If you wish to change the destination of the, click 

Browse. 

6. Follow the remaining steps. 

Registration 

When the trial period is finished, Navicat BI Viewer requires a license key or a subscription plan to continue using the 

features. 

Note: Perpetual License and Subscription Plan cannot be used at the same Navicat BI Viewer. Before changing the 

registration method, you need to deactivate the license key or sign out your Navicat ID. 

Perpetual License 

If you have purchased a perpetual license, you will receive a license key for activating Navicat BI Viewer. 

In the Perpetual License section, paste your license key (16 digits) and click the Activate button. Navicat BI Viewer 

contacts our licensing server to activate the license key. If the activation process is successful, the license key details 

are displayed. 

Manual Activation 

Manual activation is available when your computer does not have an internet connection. You will need another 

computer with an internet connection to complete this activation process. 
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1. If the online activation is failed, click Manual Activation. 

2. Copy the Request Code in the Copy the Request Code Here: box. 

3. Open web browser on a computer with an internet connection and then go to 

https://customer.navicat.com/manual_activate.php. 

4. Paste/Enter the Request Code into the left box. 

5. Click Get Activation Code. 

6. Copy the generated Activation Code in the right box. 

7. Go back to the computer where you are activating Navicat BI Viewer. 

8. Paste the Activation Code into the Paste the Activation Code Here: box. 

9. Click Activate. 

Subscription Plan 

If you have subscribed a plan, you can sign in your Navicat ID to use Navicat BI Viewer during the subscription term. 

Note: Navicat ID is the Email address that you used to subscribe the plan. 

In the Subscription section, provide your Navicat ID and Password. After signed in, the subscription plan details are 

displayed. 

Navicat BI Viewer contacts our licensing server once per hour to auto reload the plan by default. If you have updated 

your plan in the portal site, you can use the Reload Plan button to force reloading the new plan. 

Note: Each Navicat ID can connect to only one Navicat BI Viewer. If you sign in your Navicat ID in another Navicat BI 

Viewer, you will be signed out from the current Navicat BI Viewer. 

Migration / Upgrade 

Migrate Navicat BI Viewer to a new computer 

1. In Navicat BI Viewer, choose Help -> Registration. 

2. [Perpetual License] Click Deactivate to online deactivate the license key. 

3. [Subscription Plan] Click Sign Out to sign out your Navicat ID. 

4. Uninstall Navicat BI Viewer from the existing computer. 

5. Re-install Navicat BI Viewer in the new computer. 

Upgrade Navicat BI Viewer 



 6 

 

If you want to upgrade an installed copy of Navicat BI Viewer to the latest release, please choose Help -> Check For 

Updates to start the Updater. It will automatically check your installed version. If there is a new version, simply follow 

the steps in the Updater to upgrade your Navicat BI Viewer. It will replace your previous Navicat BI Viewer and your 

current settings will remain unchanged. 

Or, you can submit your registered email address on the Customer Center to download the latest version installer. 

End-User License Agreement 

Note: For the License Agreement of Navicat Cloud service, please click here. 

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT 

BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN 

ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE 

INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE 

AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE 

SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME 

BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS, 

THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE. 

THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD. 

HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN. 

1. Definitions 

a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual who is a 

natural person and not a corporation, company, partnership or association or other entity or organization (ii) the 

individual who is a student, faculty or staff member at an educational institution, and (iii) staff of a non-profit 

organization or charity organization only. For purposes of this definition, "educational institution" means a 

public or private school, college, university and other post secondary educational establishment. A non-profit 

organization is an organization whose primary objective is to support an issue or matter of private interest or 

public concern for non-commercial purposes. 

b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review and 

evaluate the Software, only. 

c. "PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any. 

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in each case, 

supplied by PremiumSoft herewith, and corresponding documentation, associated media, printed materials, 

and online or electronic documentation. 

e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the SOFTWARE 

("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation purposes for a period of 

fourteen (14) days following the initial installation of the UNREGISTERED SOFTWARE. At the end of the trial 

https://customer.navicat.com/
https://legal.navicat.com/navicatcloud/NavicatCloudLicenseAgreement.rtf
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period ("TRIAL PERIOD"), the USER must either register the SOFTWARE or remove it from his system. The 

UNREGISTERED SOFTWARE may be freely copied and distributed to other users for their evaluation. 

2. License Grants 

The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA: 

a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and store the 

Software on a storage device, such as a network server, used only to install the Software on your other 

computers over an internal network, provided you have a license for each separate computer on which the 

Software is installed and run. Except as otherwise provided in Section 2(b), a license for the Software may not 

be shared, installed or used concurrently on different computers. 

b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the computer on 

which the Software is installed may make a second copy of the Software and install it on either a portable 

computer or a computer located at his or her home for his or her exclusive use, provided that: 

A. the second copy of the Software on the portable or home computer (i) is not used at the same time as 

the copy of the Software on the primary computer and (ii) is used by the primary user solely as allowed 

for such version or edition (such as for educational use only), 

B. the second copy of the Software is not installed or used after the time such user is no longer the 

primary user of the primary computer on which the Software is installed. 

c. In the event the Software is distributed along with other PremiumSoft software products as part of a suite of 

products (collectively, the "Studio"), the license of the Studio is licensed as a single product and none of the 

products in the Studio, including the Software, may be separated for installation or use on more than one 

computer. 

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You must 

reproduce on any such copy all copyright notices and any other proprietary legends on the original copy of the 

Software. You may not sell or transfer any copy of the Software made for backup purposes. 

e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at any time, 

upon reasonable notice. In the event that such audit reveals any use of the Software by you other than in full 

compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all reasonable expenses 

related to such audit in addition to any other liabilities you may incur as a result of such non-compliance. 

f. Your license rights under this EULA are non-exclusive. 

3. License Restrictions 

a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or electronically 

transfer the Software from one computer to another or over a network. 

b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer, 

disassemble, or otherwise reduce the Software to a human-perceivable form. 
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c. Unless otherwise provided herein, you may not rent, lease, or sublicense the Software. 

d. Other than with respect to a Trial / Demo Version, Non-commercial Lite Version or a Not For Resale Version of 

the Software, you may permanently transfeOther than with respect to a Trial / Demo Version, Lite Version or a 

Not For Resale Version of the Software, you may permanently transfer all of your rights under this EULA only 

as part of a sale or transfer, provided you retain no copies, you transfer all of the Software (including all 

component parts, the media and printed materials, any upgrades, this EULA, the serial numbers, and, if 

applicable, all other software products provided together with the Software), and the recipient agrees to the 

terms of this EULA. If the Software is an upgrade, any transfer must include all prior versions of the Software 

from which you are upgrading. If the copy of the Software is licensed as part of the whole Studio (as defined 

above), the Software shall be transferred only with and as part of the sale or transfer of the whole Studio, and 

not separately. You may retain no copies of the Software. You may not sell or transfer any Trial / Demo Version, 

Lite Version or Not For Resale Version of the Software. 

e. Unless otherwise provided herein, you may not modify the Software or create derivative works based upon the 

Software. 

f. Non-commercial Versions of the Software may not be used for, or distributed to any party for, any commercial 

purpose. 

g. Unless otherwise provided herein, you shall not 

A. in the aggregate, install or use more than one copy of the Trial / Demo Version of the Software, 

B. download the Trial / Demo Version of the Software under more than one username, 

C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo Version of 

the Software for an aggregate period in excess of the trial period for one license to such Trial / Demo 

Version, 

D. disclose the results of software performance benchmarks obtained using the Trial / Demo Version or 

Lite Version to any third party without PremiumSoft prior written consent, or 

E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of determining 

whether to purchase a license to a commercial or education version of the software; provided, however, 

notwithstanding the foregoing, you are strictly prohibited from installing or using the Trial / Demo 

Version or Lite Version of the Software for any commercial training purpose. 

h. You may only use the Not for Resale Version of the Software to review and evaluate the Software. 

i. You may receive the Software in more than one medium but you shall only install or use one medium. 

Regardless of the number of media you receive, you may use only the medium that is appropriate for the 

server or computer on which the Software is to be installed. 

j. You may receive the Software in more than one platform but you shall only install or use one platform. 

k. You shall not use the Software to develop any application having the same primary function as the Software. 
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l. In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you must 

destroy all copies of the Software (with all other rights of both parties and all other provisions of this EULA 

surviving any such termination). 

m. This program may include Oracle Instant Client (OCI). You agree that you shall 

1. not use of the Oracle Instant Client to the business operations; 

2. not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual or 

entity; 

a. make the Programs available in any manner to any third party for use in the third party's 

business operations; and 

b. title to the Programs from passing to the end user or any other party; 

3. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the 

Programs except for a sufficient number of copies of each Program for your licensed use and one copy 

of each Program media; 

4. discontinue use and destroy or return to all copies of the Oracle Instant Client and documentation after 

termination of the Agreement; 

5. not publish any results of benchmark tests run on the Programs; 

6. comply fully with all relevant export laws and regulations of the United States and other applicable 

export and import laws to assure that neither the Oracle Instant Client, nor any direct product thereof, 

are exported, directly or indirectly, in violation of applicable laws; 

7. allow PremiumSoft to audit your use of the Oracle Instant Client; 

4. Upgrades 

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license 

exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your 

earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person or 

entity unless such transfer is pursuant to Section 3. 

5. Ownership 

The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, title 

and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent work and 

as an underlying work serving as a basis for any application you may develop), and all copies thereof. All rights not 

specifically granted in this EULA, including Federal and International Copyrights, are reserved by PremiumSoft and its 

suppliers. 

6. LIMITED WARRANTY AND DISCLAIMER 
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a. Except with respect to Trial / Demo Version, Lite Version and Not For Resale Version of the Software, 

PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as evidenced by a copy of 

your receipt): the physical media on which the Software is furnished will be free from defects in materials and 

workmanship under normal use. The Software is provided "as is". PremiumSoft makes no warranties, express 

or implied, arising from course of dealing or usage of trade, or statutory, as to any matter whatsoever. 

b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version, Lite 

version and the Not for Resale version of the Software. Trial / Demo version, Lite version and the Not for 

Resale version of the Software are provided "as is". 

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo version, 

Lite version and Not for Resale version, PremiumSoft and its suppliers disclaim all other warranties and 

representations, whether express, implied, or otherwise, including the warranties of merchantability or fitness 

for a particular purpose. Also, there is no warranty of non-infringement and title or quiet enjoyment. 

PremiumSoft does not warrant that the Software is error-free or will operate without interruption. The Software 

is not designed, intended or licensed for use in hazardous environments requiring fail-safe controls, including 

without limitation, the design, construction, maintenance or operation of nuclear facilities, aircraft navigation or 

communication systems, air traffic control, and life support or weapons systems. PremiumSoft specifically 

disclaims any express or implied warranty of fitness for such purposes. 

d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in duration 

to thirty (30) days from the date of delivery. 

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or employees 

shall create a warranty or in any way increase the scope of ANY warranty PROVIDED HEREIN. 

7. LIMITATION OF LIABILITY 

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental, 

punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or access 

data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability to use, the 

Software and based on any theory of liability including breach of contract, breach of warranty, tort (including 

negligence), product liability or otherwise, even if PremiumSoft or its representatives have been advised of the 

possibility of such damages. 

8. Third Party Software 

The Software may contain third party software which requires notices and/or additional terms and conditions. By 

accepting this EULA, you are also accepting the additional terms and conditions of the third party software. 

9. General 

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA. 

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and 

supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that any 
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varying or additional terms contained in any purchase order or other written notification or document issued by you in 

relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to exercise any of 

its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those rights or of the 

breach. 

If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision will 

be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full force and 

Effect. 

10. Basis of Bargain 

The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of the 

agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an economic 

basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the benefit of 

PremiumSoft's licensors. 

11. Term 

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA. 

This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to 

comply with any term of this License. 

"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or statutory, 

as to any matter whatsoever. In particular, any and all warranties or merchantability, fitness for a particular purpose or 

non-infringement of third party rights are expressly excluded. 

12. License Termination 

Without prejudice to any other rights, PremiumSoft may terminate this EULA if you fail to comply with the terms and 

conditions of this EULA. In such event, you must destroy all copies of the software and all of its component parts. 

13. Governing Law 

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive jurisdiction 

and venue sitting in Hong Kong to resolve any disputes arising under this EULA. 

Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If you 

desire to contact the Licensor for any other reason, please contact support@navicat.com. 

PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of PremiumSoft 

CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, product names and 

logos may be the trademarks or registered trademarks of their respective owners. You may not remove or alter any 

trademark, trade names, product names, logo, copyright or other proprietary notices, legends, symbols or labels in the 

Software. This EULA does not authorize you to use PremiumSoft or its licensors names or any of their respective 

trademarks. 
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Chapter 2 - User Interface 

Main Window 

 

 Navigation Pane 

The Navigation pane allows you to open local workspace files, recently opened workspace files, or workspace files in 

Navicat Cloud / On-Prem Server. If the Navigation pane is hidden, choose View -> Show Navigation Pane from the 

menu bar. 

 Content Pane 

The Content pane contains the workspaces that are in the selected section of Navigation pane. To change the view, 

click the  Detail or  Icon buttons. 

 Information Pane 

The  General tab shows the general information of the workspace or the selected item. 

The  Project tab shows the project members and the project activities done by the members. Click + to add 

members to the project. 

If the Information pane is hidden, choose View -> Show Information Pane from the menu bar. 

Workspace Window 

A workspace is the place that comprises dashboards and charts. You can view multiple dashboards and charts in a 

workspace. 
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 Tab Bar 

The Tab Bar allows you to switch among the opened items. 

 Content Pane 

The Content pane shows all items in the workspace. To change the view, click the  Detail or  Icon button at the 

bottom of the window. 

Detail View displays additional information about each item. You can sort items in Detail View, click the column header 

by which you want to sort the items. 

Icon View displays your items as a grid of thumbnail images. You can filter the items by clicking a category (All, Chart, 

Dashboard) in this view. 

 Properties Pane 

The  General tab shows the general information of the workspace or the selected item. 

The  Using tab shows the items that the selected item depends on. 

The  Used By tab shows the items that depend on the selected item. 

If the Properties pane is hidden, choose View -> Show Properties from the menu bar. 
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Chapter 3 - Collaboration 

About Collaboration 

Navicat BI Viewer allows you to synchronize connection settings, BI workspaces and virtual group information from 

Navicat BI, other Navicat family members, different machines and different platforms. You can use Navicat Cloud to host 

the files. Or, if you have installed our another product, Navicat On-Prem Server, in your environment, you can hosts 

everything in-house. 

Our collaboration feature allows you to give your teammates access to your projects when they log into their accounts. 

That way, you and your teammates can work on the same project without revealing your username and password. You 

can even choose to restrict the type of access your teammates have to your project. 

Manage Cloud 

Navicat Cloud 

Navicat Cloud is a cloud service provided by PremiumSoft for synchronizing connection settings, queries, aggregation 

pipelines, snippets, model workspaces, BI workspaces and virtual group information. 

Navicat Cloud could not connect and access your databases. By which it means, it could only store your connection 

settings, queries, aggregation pipelines, snippets, model workspaces, BI workspaces and virtual group information; your 

database passwords and data (e.g. tables, views, etc) will not be stored to Navicat Cloud. 

Note: You can only sign in to one Navicat Cloud account in the software. PremiumSoft will keep all synchronized files 

strictly confidential, and all employees are prohibited from viewing/accessing content of files you may store in your 

Navicat Cloud account. 

Create Navicat Cloud Account 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click Create Navicat ID. 

4. Enter the required information and click Sign Up. A verification email will send to your email address. 

5. Click the link in the email to verify the new account. 

Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center. 

Sign In Navicat Cloud 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, select Navicat Cloud. 
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3. Enter your Navicat ID and Password. 

4. Click Sign In. 

5. If you enabled two-step verification in Navicat Cloud Portal, a code will be sent to your phone via your mobile 

app. Enter the received code to sign in. 

Sign Out Navicat Cloud 

1. Close all workspaces in Navicat Cloud. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select Navicat Cloud. 

4. Click Sign Out. 

View Usage 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Your usage and current plan will be shown. 

Change Your Picture 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click your avatar. 

4. Choose an image file. 

Manage Your Account 

You can change your password, enable Two-Step Verification, upgrade Cloud Plan, etc in Navicat Cloud Portal. 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud. 

3. Click Manage Account. 

4. A web browser will automatically open up to Navicat Cloud Portal. 

https://cloud.navicat.com/
https://cloud.navicat.com/
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On-Prem Server 

Navicat On-Prem Server is an on-premise solution that provides you with the option to host a cloud environment for 

storing Navicat objects (connection settings, queries, aggregation pipelines, snippets, model workspaces, BI 

workspaces and virtual group information) internally at your location. 

Before you can add an On-Prem Server, you must first set up Navicat On-Prem Server in your environment. 

Note: You can add multiple On-Prem Server in the software. 

Add New On-Prem Server 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server. 

3. Enter your On-Prem Server login information. 

Option Description 

Host The host name or IP address of your On-Prem Server. 

Port The port number of your On-Prem Server. 

Verify Server Certificate Enable this option to verify the server certificates. 

Enable Push 

Synchronization 

Navicat BI Viewer receives a silent push notification whenever its 

files stored in your On-Prem Server changes. 

4. Click OK. 

Add New On-Prem Server with URI 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, click + New On-Prem Server -> New On-Prem Server with URI. 

3. Paste your On-Prem Server URI. 

4. Click OK. 

Note: The URI can be copied from your On-Prem Server portal site. 

Sign In On-Prem Server 

1. In the menu bar, choose File -> Manage Cloud. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Enter your Username and Password. 

4. Click Sign In. 
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5. If you enabled two-step verification, a code will be sent to you via the verification method you have selected. 

Enter the received code to sign in. 

Sign Out On-Prem Server 

1. Close all workspaces in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

Edit On-Prem Server 

1. Close all workspaces in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Right-click your server and select Edit On-Prem Server. 

6. Edit the On-Prem Server information. 

7. Sign in your server. 

Rename On-Prem Server 

1. Close all workspaces in your On-Prem Server. 

2. At the top right, click your avatar. 

3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Right-click your server and select Rename. 

6. Enter the name to describe your On-Prem Server. 

7. Sign in your server. 

Remove On-Prem Server 

1. Close all workspaces in your On-Prem Server. 

2. At the top right, click your avatar. 
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3. In the Manage Cloud window, select the On-Prem Server. 

4. Click Sign Out. 

5. Right-click your server and select Remove On-Prem Server. 

6. Click Delete. 

View Usage 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Your usage will be shown. 

Change Your Picture 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Click your avatar. 

4. Choose an image file. 

Manage Your Account 

You can change your password, enable Two-Step Verification, etc in your On-Prem Server web portal. 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select the On-Prem Server. 

3. Click Manage Account. 

4. A web browser will automatically open up to your On-Prem Server web portal. 

Push Synchronization 

Push Synchronization enables Navicat BI Viewer to receive a silent push notification whenever the files stored in 

Navicat Cloud or On-Prem Server changes. 

Enable Push Synchronization 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, right-click Navicat Cloud or your On-Prem Server. 
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3. Turn on Enable Push Synchronization. 

Disable Push Synchronization 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, right-click Navicat Cloud or your On-Prem Server. 

3. Turn off Enable Push Synchronization. 

Cache and Local Copies 

When you logged into Navicat Cloud or your On-Prem Server, Navicat BI Viewer saves the cloud object files and some 

information in the local computer. The cache and local copies use to make sure your changes are saved in the cloud. 

Clear Cache and Local Copies 

1. At the top right, click your avatar. 

2. In the Manage Cloud window, select Navicat Cloud or your On-Prem Server. 

3. Click Sign Out. 

4. Right-click Navicat Cloud or your On-Prem Server and select Clear Cache and Local Copies. 

5. Click Clear. 

Open Containing Folder 

1. In the main window, select Navicat Cloud or your On-Prem Server. 

2. Open your project. 

3. Right-click anywhere in the project and select Open Containing Folder. 

Projects 

Work With Projects 

A project is a way to structure and organize Navicat objects. You can put related objects in one project, and then share 

the project with other accounts for collaboration if necessary. 

Create New Projects 

1. In the main window, select Navicat Cloud or your On-Prem Server. 

2. Click + New Project. 

3. Enter the name of the new project. 
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4. Click OK. 

Manage Existing Projects 

To rename a project 

1. In the main window, right-click the project and select Rename. 

2. Enter a new project name. 

Note: Only the project owner and the members with the Can Manage & Edit right can rename the project. 

To delete a project 

1. In the main window, right-click the project and select Delete Project. 

2. Click Delete. 

Note: Only the project owner can delete the project. 

Note: Before you delete the project, you must remove all objects in the project. 

To quit a project 

1. In the main window, right-click the project and select Quit Project. 

2. Click Quit. 

Manage Members 

Add Members 

1. In the main window, right-click the project and select Manage Members. 

2. Click Add Members. 

3. [Navicat Cloud] Enter the member's Navicat ID and press ENTER. 

4. [On-Prem Server] Check the boxes of the users that you want to add. 

5. Select the member right. 

6. Click Add. 

Member Rights Privileges 

Can Manage & Edit Read Objects, Write Objects, Manage Members and Rename 

Projects 

Can Edit Read Objects and Write Objects 

Can View Read Objects 
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Manage Existing Members 

To edit the right of a member 

1. In the main window, right-click the project and select Manage Members. 

2. Use the drop-down list next to the member to change the right. 

3. Click Apply. 

To remove a member from a project 

1. In the main window, right-click the project and select Manage Members. 

2. Click the X icon next to the member. 

3. Click Apply. 
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Chapter 4 - Workspace Handling 

Open Workspace 

There is not necessary to establish server connections to view your workspace file if the data sources are set to the 

archive mode. However, please bear in mind that all data sources in the archive mode will not contain the most 

up-to-date data. 

Open Local Workspace File 

If you have been provided with a workspace file (.nbi), you are allowed to view its dashboards. 

1. In the menu bar, choose File -> Open -> Workspace. 

2. Browse your workspace file. 

3. Enter the passwords for connecting the servers set in the data sources. 

Hint: You can clear all saved passwords in a workspace by choosing File -> Clear All Passwords in Workspace. 

Open Workspace in Navicat Cloud 

If you have logged in Navicat Cloud, you can open the workspace files that are synchronized to your Navicat ID. 

1. In the main window, select Navicat Cloud in the Navigation pane. 

2. Open a project. 

3. Open your workspace file. 

4. Enter the passwords for connecting the servers set in the data sources. 

Hint: You can clear all saved passwords in a workspace by choosing File -> Clear All Passwords in Workspace. 

Open Workspace in On-Prem Server 

If you have added and logged in your On-Prem Server, you can open the workspace files that are synchronized to your 

user account. 

1. In the main window, select your On-Prem Server in the Navigation pane. 

2. Open a project. 

3. Open your workspace file. 

4. Enter the passwords for connecting the servers set in the data sources. 

Hint: You can clear all saved passwords in a workspace by choosing File -> Clear All Passwords in Workspace. 



 24 

 

Present Chart / Dashboard 

You can present charts and dashboards and using the whole screen. The title bar, Pages pane and Properties pane 

will be hidden while in this mode. To open a chart or a dashboard in present view, click  or Present in the Properties 

pane. 

Use the arrow keys to navigate between pages. 

To exit present view, press the ESC key and the workspace window will be returned to its previous state. 

Chart Interaction 

If chart interaction is turned on, you can select a data point on one of the charts and all the other charts on the 

dashboard page that contain the same data will change based on your selection. 

 

If the dashboard contains a control chart, you can filter the data series of all charts by using the control. 

Sort Chart 

In the Present mode, you can organize your data in a chart with one click. You can sort data series by a value. 

1. Hover over a chart until you see the  icon in the upper-right corner. 

2. Click the  icon to sort on a different value and select the sorting order. 

Print & Export 

Print to a printer 

Choose File -> Print to send your dashboard pages directly to the printer. You can set the printer option in the pop-up 

window. 

Export to a file 

Choose File -> Export To and choose the file format to create a PDF, PNG, SVG or JPG file of your dashboard pages. 
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Chapter 5 - Other Advanced Tools 

Useful Features 

Navicat BI Viewer provides variety of tools that improve user experience when working on workspaces. 

• Search Filter 

• Dark Theme 

Share via URI 

Navicat BI Viewer allows you share a workspace with your teammates by the URL of the workspace. Navicat users can 

use the generated URI to access the workspace. 

Obtain URI 

You can obtain the URI of a workspace in the General tab of the Information pane. Simply click Share and copy the 

URI in the popup window. You can enable Hide host info to remove the connection host parameter in the URI. 

Open Object via URI 

1. In the main window, choose File -> Open with Navicat URI. 

2. Paste the URI. 

3. Click OK. 

4. Change the connection mapping by clicking Other Options if necessary. 

Option Description 

Mapped Connection Automatically map the connection in the URI to the connection with 

the most similar information in Navicat. 

Existing Connection Choose an existing connection in Navicat. 

New Connection Create a new connection in Navicat. 

5. Open the object. 

Search Filter 

Navicat BI Viewer provides search filters for searching your objects in the main window and tree structures. 

In the main window, enter a search string in the  Search text box. 

In the tree structures, click on the tree to focus and enter a search string directly. 

You can remove the filter by deleting the search string. 
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Dark Theme 

In Dark Theme, Navicat BI Viewer uses a darker color palette for all windows, views, menus, and controls. It works on all 

supported versions of Windows. 

To change your theme, choose File -> Options -> General. Then, select Dark.  
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Chapter 6 - Configurations 

Options Settings 

Navicat BI Viewer provides several options for customizing its user interface and performance. 

To open the Options window, choose File -> Options from the menu bar. 

General 

General 

Theme 

Choose to use the theme of your Windows OS or a Dark theme. 

Hint: Restart Navicat BI Viewer to take effect. 

Check for updates on startup 

Check this option to allow Navicat BI Viewer checks for new version when it starts. 

Usage Data 

Share Usage Data 

Check this option to let your device sends us information about how you use Navicat BI Viewer to help us improve it. You 

can view the information being shared by clicking the Usage Data button. 

File Locations 

Logs Location 

Navicat BI Viewer provides number of log files to keep track on the actions have been performed in Navicat BI Viewer 

and they are located in the Logs Location path. 

Profiles Location 

The internal files of Navicat BI Viewer are located in the Profiles Location path. 

Connectivity 

General 

Verify server certificate against CA 

Enable this option to verify that the server certificate against the list of trusted CA. 
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Proxy 

Enable the Use proxy option to configure Navicat BI Viewer to use proxy in order to make its network connections. 

Proxy Type 

Specify the type of your proxy server: HTTP or SOCKS5. 

Host 

The host name of your proxy server. 

Port 

The port number of your proxy server. 

User Name / Password 

If your proxy server requires authentication, you can enter a username and a password. 

Connectivity Diagnosis 

Click Test Connectivity to test the network connectivity between the web service and your machine. 

Environment 

OCI Environment 

OCI library (oci.dll) 

Specify the location of the OCI library (oci.dll) for Oracle connection. By default, it is set to the bundled one in Navicat BI 

Viewer installation folder. 

Hint: Restart Navicat BI Viewer to take effect. 

Oracle Instant Client is the simplest way to deploy a full Oracle Client application built with OCI, OCCI, JDBC-OCI, or 

ODBC drivers. It provides the necessary Oracle Client libraries in a small set of files. You can also download Oracle 

Instant Client through - 

Oracle Instant Client 

Download the appropriate Instant Client packages for your platform and the CPU. All installations REQUIRE the Basic 

or Basic Lite package. Unzip the packages and set the path points to it. 

Advanced 

Enable diagnostic logging 

https://www.oracle.com/database/technologies/instant-client/downloads.html
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Generate a log file in Logs Location to assist with tracking down any problems in Navicat BI Viewer. 

Hint: Restart Navicat BI Viewer to take effect. 

Register on "Open with" List 

Register Navicat BI Viewer program to the "Open with" list in Windows. 

Register Navicat URI Protocol 

Register Navicat URI protocol in Windows. When clicking a Navicat URI link, Navicat BI Viewer opens and adds the 

corresponding Navicat On-Prem Server using the parameters in the URI. 
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Chapter 7 - Hot Keys 

BI Viewer Hot Keys 

Keys Action 

F5 Present Dashboard 

CTRL+P Print Dashboard 

CTRL+R Refresh Data 

F11 Focus Mode 

CTRL+U Open with Navicat URI 

CTRL+TAB Next Window 
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Chapter 8 - Trace Logs 

Log Files 

Navicat BI Viewer provides number of log files to keep track on the actions have been performed in Navicat BI Viewer 

and they are located in the logs directory, e.g. C:\Users\Guest\Documents\Navicat BI Viewer\logs\. You are allowed to 

change the log files location under Options. 

File Description 

history.log Store the statements or scripts of all operations executed over databases and 

database objects in Navicat BI Viewer. 

Note: This log will be overwritten while Navicat BI Viewer is being restarted. 

navicat.log Store information to assist with tracking down any problems in Navicat BI 

Viewer. You can enable this log in Options. 

Note: This log will be overwritten while Navicat BI Viewer is being restarted. 

 


